User Tools

Site Tools


wiki:openbsd


Wiki

OpenBSD

Official site: www.openbsd.org
Typical usage of programs like sed, gzip, … can be found in linux-unix section.

Disk Management

Disk Spin-off Management

smartctl -A /dev/ad0 | grep Load

If this value is increased every few minutes, you have the problem ! And your hard disk could be break only in few months ! Each time parking occures, you can hear a “click” from your disk.

Normally, you must have only few cycles per day!

There is a solution, set the hard disk to most performance (and most energy consumption) with the utility: ataidle (I installed it with the ports /usr/ports/sysutils/ataidle)

Then you can type: ataidle -P 254 /dev/ad0 and it will save your hard drive :evil:

atactl /dev/wdXc apmset 253

If you want to do it at boot, add to your rc.conf

ataidle_enable=“YES”
ataidle_device=“ad0”
ataidle_ad0=“-P 254”

Format Disk

fdisk -i sdX
disklabel -e sdX
newfs sdXZ
mount /dev/sdXZ /mnt

http://www.openbsd.org/faq/faq14.html

IPSec VPN

Display current VPN Tunnels:

ipsecctl -sa

Start daemon and load configs:

isakmpd -K
ipsecctl -f /etc/ipsec.conf

PF

Display table content

pfctl -t %TABLENAME% -T show

Display current status

pfctl -s all

Display pflog content

tcpdump -n -e -ttt -r /var/log/pflog

Display pflog real-time

tcpdump -n -e -ttt -i pflog0

Reset root Password

Boot in user mode

boot> boot -s

2. Now run fsck on all partitions, to make sure things are okay for changes

Enter pathname of shell or RETURN for sh: <press enter> # fsck -p

3. Mount all filesystems # mount -a

export the TERM environmental variable only if you need to edit files: # export TERM=vt220

4. Reset root's password and then reboot

# passwd Changing local password for root. New password: ILikeMonkeys Retype new password: ILikeMonkeys # shutdown -r now

Restart Daemons

kill -HUP `cat /var/run/%DAEMON%.pid`

System Management

List binded ports

lsof -i
fstat | grep .%PORT%

Mount SMB Share

To mount SMB/CIFS shares, use sharity-light (windowsserver must be added to /etc/hosts).

pkg_add sharity-light
shlight //windowsserver/backup /mnt/backup -U windows_user -P someuglypassword
unshlight -a [node]

Poweroff

To poweroff after shutdwon:

halt -p

or

powerdown=YES

in /etc/rc.shutdown file

System Setup

Afterboot

/usr/libexec/locate.updatedb &

Dowload http://mirror.switch.ch/ftp/pub/OpenBSD/packages/i386/index.txt to /root

Add

/etc/rc.d/dbus start

in the /etc/rc.local file.

Start apmd modifying the line apmd_flags to

apmd_flags="-A"

in /etc/rc.conf.local

Programs To Install

Command Line

pkg_add iperf
pkg_add wget
pkg_add kismet

X

pkg_add pidgin
pkg_add xbatt
pkg_add xbattbar
pkg_add wmapm
pkg_add wmwlmon
pkg_add xpdf
pkg_add rox-filer
pkg_add firefox
pkg_add xloadimage
pkg_add ristretto
pkg_add nedit
pkg_add libre-office
pkg_add mozilla-dicts-fr
pkg_add mozilla-dicts-it
pkg_add mozilla-dicts-de

XFCE4

Put the following text in the xfcepkglist file:

xfwm4
gtk-xfce-engine
libxfce4ui
libxfce4util
libxfcegui4
notification-daemon-xfce
xfce-utils
xfce4-appfinder
xfce4-battery
xfce4-clipman
xfce4-cpugraph
xfce4-dict
xfce4-diskperf
xfce4-fsguard
xfce4-genmon
xfce4-icon-theme
xfce4-mailwatch
xfce4-mixer
xfce4-modemlights
xfce4-mount
xfce4-mpc
xfce4-netload
xfce4-notes
xfce4-notifyd
xfce4-panel
xfce4-places
xfce4-power-manager
xfce4-quicklauncher
xfce4-screenshooter
xfce4-session
xfce4-settings
xfce4-smartbookmark
xfce4-systemload
xfce4-taskmanager
xfce4-terminal
xfce4-time-out
xfce4-verve
xfce4-wavelan
xfce4-weather
xfce4-wmdock
xfce4-xkb

and execute:

pkg_add -i `cat xfcepkglist`

To run xfce do “startxfce4”

Customize

Copy /etc/X11/xinit/xinitrc to ~/.xinitrc and add or remove programs to launch in fvwm.

FVWM is the default Window Manager. The configuration file is .fvwmrc in /usr/X11R6/lib/X11/fvwm/ or in the user's home dir. This is the configuration to add some applications to the menu.

''AddToMenu RootMenu	"Root Menu"	Title
+			"XTerm%mini.xterm.xpm%"		Exec exec xterm
+			"FireFox"			Exec exec firefox
+			"Thunderbird"			Exec exec thunderbird
+			"Nedit"				Exec exec nedit''

To set a different background:

''######################## Initialization Functions ############################
AddToFunc InitFunction 	  "I" Module FvwmPager 0 0
AddToFunc InitFunction	  "I" Module FvwmBacker''

If you have problems on screen resolution, change to this the same section of xorg config file:

Section "Monitor"
        Identifier      "Configured Monitor"
        HorizSync       28-73
EndSection

You can configure and generate the xorg config file using the command “X -configure” and try the configuration using “X -config ./xorg.conf.new”.
The correct file need to be copied to /etc/X11/xorg.conf.

Sendmail

Modify files in /usr/share/sendmail/cf/ (/usr/share/sendmail/cf/openbsd-localhost.mc)

Build cf file:

m4 ../m4/cf.m4 openbsd-localhost.mc > openbsd-localhost.cf

Copy result to the /etc/mail directory

Restart the sendmail daemon

Shell

Make changes in .bashrc immediately available

$ . ~/.bashrc

Spamd

Updgrade

New method since 6.5:

sysupgrade
pkg_delete -a
pkg_add -ui

and to patch:

syspatch

Install new version with the iso installer

After reboot:

sysmerge

or

sysmerge [-S] -s /mnt/%VERSION%/i386/etc%VERSION%.tgz -x /mnt/%VERSION%/i386/xetc%VERSION%.tgz

Merge configs files by hand when needed

Upgrade the packages:

fw_update
pkg_delete -a
pkg_add -ui

VMWare Images

You can find pre-installed OpenBSD VMWare images at this site: http://chrysaor.info/

ToDo

wiki/openbsd.txt · Last modified: 2020/02/04 09:54 by ach